Hep problems to start with api

Market data, Trading, Technical support, Features requests, etc
Post Reply
kullboys
Posts: 1
Joined: Tue Mar 12, 2019 7:00 am

Hep problems to start with api

Post by kullboys » Tue Mar 12, 2019 7:01 am

Hi,

I usually code in C++ and I need some help to start coding for Bookmap.
I installed Eclipse and copied the jre directory from bookmap into the eclipse directory, hoping it's all I need to create my own jar files but I end up with this error:
java.lang.UnsupportedClassVersionError: velox/api/layer1/layers/tradinghelper/Layer1ApiHelperChaseStrategy has been compiled by a more recent version of the Java Runtime (class file version 54.0), this version of the Java Runtime only recognizes class file versions up to 52.0
Wich JRE is needed?
Thanks.

serhii
Posts: 7
Joined: Fri Jul 13, 2018 1:07 pm

Re: Hep problems to start with api

Post by serhii » Wed Mar 13, 2019 12:09 pm

Hi, we use JDK 8 to build our jars.

As I understand you are compiling on JDK 10 (class version 54) and then trying to run on JRE 8 (class version up to 52)

To fix this you need to compile on compliance level 1.8 (JDK 8)
You can specify it in Eclipse settings
try this:
Project menu > Properties > Java Compiler > Compiler compliance level > 1.8

Even better would be to install JDK 8 and set eclipse to use it for compilation.

Post Reply