Problem with NT8 Rithmic Connection

Market data, Trading, Technical support, Features requests, etc
ricktrader911
Posts: 2
Joined: Tue Oct 22, 2019 4:59 pm

Problem with NT8 Rithmic Connection

Post by ricktrader911 » Tue Oct 22, 2019 5:03 pm

I have an issue with connecting Rithmic on NT8. I just transferred over to Rithmic. I use my new username and password and it says my credentials are invalid. I emailed support and have not heard anything back. Thank you.

Sandra
Posts: 43
Joined: Wed Dec 12, 2018 12:37 pm
Has thanked: 1 time
Been thanked: 4 times

Re: Problem with NT8 Rithmic Connection

Post by Sandra » Wed Oct 23, 2019 8:20 am

This problem was resolved via the Support Ticket system.

coeurtrade2020
Posts: 1
Joined: Sat Mar 25, 2023 7:17 pm

Re: Problem with NT8 Rithmic Connection

Post by coeurtrade2020 » Mon Mar 27, 2023 7:24 pm

Hello,

I purchased Add-On yesterday and try to connect to the Rithmic data, but it keep saying invalid credential. 

nmarkidis
Posts: 3
Joined: Sat Jul 03, 2021 3:23 pm

Re: Problem with NT8 Rithmic Connection

Post by nmarkidis » Wed Mar 29, 2023 10:00 am

Hi,

1. Please make sure that your credentials are correct. Especially check if the email ends with @bookmap.com (if you purchased it through Bookmap) and make sure that email/password do not include any white space.


2. Make sure that under Rithmic connectivity window (Connections > uncheck Rithmic box > Configure > Rithmic) the System is set under Rithmic paper trading (for data only accounts) and is set to Rithmic 01 (if you connect to your Broker). Also make sure that the plugin mode box is unchecked (unless you use the R Trader Pro software)


3. Make sure to sign the Rithmic agreements first by clicking "here" as requested in the popup you get


For more info you can also check this video guide explaining how to establish the connection to Rithmic:
https://www.youtube.com/watch?v=yqtfOXW3Zmg

If you are still facing issues please email us at support@bookmap.com with a screenshot of the Rithmic configuration window.

Post Reply