VWAP Standard Deviation Indicator

terminhandler
Posts: 10
Joined: Tue Jul 05, 2022 5:41 pm
Has thanked: 1 time
Been thanked: 1 time

Re: VWAP Standard Deviation Indicator

Post by terminhandler » Tue Sep 12, 2023 2:18 am

I then removed it, closed and restarted Bookmap. When I added the module, it threw the same exception.

zcsoka
Posts: 295
Joined: Thu Dec 19, 2019 7:50 pm
Has thanked: 2 times
Been thanked: 28 times

Re: VWAP Standard Deviation Indicator

Post by zcsoka » Tue Sep 12, 2023 5:50 am

I believe wrong timestamp was configured for the Reset TimeStamp. For the hour it seems first 113 and then 900 was configured. I have prepared a version which ignores wrong timestamp, please find it attached. Give it at try.

z0li-2.3.1.jar
(83.06 KiB) Downloaded 532 times

terminhandler
Posts: 10
Joined: Tue Jul 05, 2022 5:41 pm
Has thanked: 1 time
Been thanked: 1 time

Re: VWAP Standard Deviation Indicator

Post by terminhandler » Wed Sep 13, 2023 2:50 am

Thank you very much! That seemed to fix the problem. I loaded it to BM in both trading and replay modes and it the issue hasn't surfaced again.

terminhandler
Posts: 10
Joined: Tue Jul 05, 2022 5:41 pm
Has thanked: 1 time
Been thanked: 1 time

Re: VWAP Standard Deviation Indicator

Post by terminhandler » Wed Apr 10, 2024 4:58 am

Hello again, Zoli. I'm using z0li-2.3.1.jar which you sent me a few months ago. It was working fine until today when it threw an exception when I entered the hh:mm:ss for a VWAP reset. Attached please see screenshots and the stack trace. Looking forward to you help again. Thank you and best regards,
Attachments
Capture2.JPG
Capture2.JPG (83 KiB) Viewed 1419 times
Capture.JPG
Capture.JPG (92.1 KiB) Viewed 1419 times
stack trace.txt
(2.29 KiB) Downloaded 80 times

zcsoka
Posts: 295
Joined: Thu Dec 19, 2019 7:50 pm
Has thanked: 2 times
Been thanked: 28 times

Re: VWAP Standard Deviation Indicator

Post by zcsoka » Wed Apr 10, 2024 6:37 am

Your time stamp is not correct, you have entered:
"57`"
the extra` causes the trouble. Please remove it if you can. If it blocks the plugin to load, unfortunately you need to edit the Bookmap config file in the Config folder (bookmap_config_vXX.json). Open it in a text editor, look for the text "57`" and remove the extra character. Save the config and try to start Bookmap.

Post Reply